P3Dv5.2 Compatibility

We are glad to announce that all our products are now fully compatible with P3D v5.2 which was released last week by Lockheed Martin.

This update round took a bit longer than we initially expected as shaders quite drastically changed and this required a full rework of some of our shader tweaks.


The updates are now available through Envupdater and standalone patches will also soon be available from your SimMarket account. While this update is mainly focused on v5.2 compatibility, we are still looking at improving your experience and that's why we will also have some very exciting news later this summer :D Happy flights !



2,498 views5 comments

Recent Posts

See All